#1497: Ошибка с доступ к базе знаний: Ошибка Error: Instance not found!
Отредактирована: сегодняСимптомы
Ошибка при открытии базы знаний:
Ошибка Error: Instance not found!
В логах контейнера swarmica-helpcenter-1 наблюдается ошибка:
[app] ERROR { status: 400, method: 'GET', url: 'http://django:5000/api/instance/' }
Или:
[app] ERROR { status: undefined, method: 'GET', url: 'https://my.swarmica.tld/api/instance/' }
Решение
Для решения проблемы необходимо выполнить следующие шаги:
- Добавить значение django через запятую в переменную
DJANGO_ALLOWED_HOSTSв файле/root/swarmica/.env,например:DJANGO_ALLOWED_HOSTS=my.swarmica.tld,django. - Раскомментировать строку
INSECURE_HTTP_SERVER=1 - Установить значение переменной
NEXT_PUBLIC_HELPCENTER_SERVER_API_URL=http://django:5000 - Перезагрузить контейнеры с помощью команды:
docker compose down && docker compose up -d
Причина
Сервер со Свормикой не доступен сам себе по через внешнюю сеть ввиду сетевых настроек.