Симптомы
Клиент завел тикет, в котором нет найденных результатов, хотя статья про это есть.
Решение
Методология KCS очень настоятельно рекомендует описывать симптомы теми же словами и так, как их видит клиент.
Нужно дополнить статью в разделе симптомы, используя ключевые слова, которыми клиент описывает свою проблему.
Причина
Поисковый движок PostgreSQL ищет всю фразу, разбивая ее на словоформы.
Клиент ввел слово "Блокировка SIP" , но нужная статья не нашлась, потому что в ней вообще нет слова "Блокировка", хотя в целом она конечно описывает кейс клиента.
Причина здесь в том, что инженеры имеют тенденцию описывать кейсы на своем языке, а нужно обязательно использовать слова клиента для того, чтобы они (клиенты) могли находить статью, когда пишут своими словами.