Симптомы
Настроен почтовый канал support@company.com, при добавлении внутреннего комментария почта отправляется от support@company.com, а не support+internal@company.com.
Почта управляется Google (GSuite / Google Workspace / Gmail).
В заголовках почтового сообщения видно следующее:
From: Support <support@company.com>
X-Google-Original-From: Support <support+internal@company.com>
Subject: Test delivery
To: recepient@other-company.com
Reply-To: Support <support+internal@company.com>
Решение
Необходимо настроить дополнительный адрес на стороне аккаунта Google Mail
- Войдите в почтовое приложение под учетной записью канала support@company.com
- Нажмите иконку

- Нажмите Все настройки > Аккаунты и Импорт
- Пролистайте до раздела Отправлять письма как и нажмите Добавить другой адрес почты

- Добавьте адрес с суффиксом +internal перед @, то есть, для нашего примера это будет support+internal@company.com
- Уберите галочку Использовать как псевдоним и нажмите Далее

Причина
Начиная с 2025 года, Google поменял механизм работы с алиасами вида "+alias" и теперь по умолчанию подменяет такие алиасы на изначальный адрес, сохраняя изначальное поле From в заголовок X-Google-Original-From